summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-12-01 12:04:58 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-01 16:50:05 +0100
commita03182ad020e01744f783a8668c29cc6e8008122 (patch)
tree5a92cd9465d9851a5c837a4b529e5efb61c9d165 /boot/uboot
parent0239612fb2af681984af222c9a84bf06ce9b77ec (diff)
downloadbuildroot-novena-a03182ad020e01744f783a8668c29cc6e8008122.tar.gz
buildroot-novena-a03182ad020e01744f783a8668c29cc6e8008122.zip
u-boot: add support for u-boot-nand.bin
Add support for the u-boot-nand.bin target file. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in3
-rw-r--r--boot/uboot/uboot.mk2
2 files changed, 5 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index dd49a2c23..f154bd123 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -85,6 +85,9 @@ choice
config BR2_TARGET_UBOOT_FORMAT_BIN
bool "u-boot.bin"
+config BR2_TARGET_UBOOT_FORMAT_NAND_BIN
+ bool "u-boot-nand.bin"
+
config BR2_TARGET_UBOOT_FORMAT_KWB
depends on BR2_arm
bool "u-boot.kwb (Marvell)"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index cf2231211..db9de8d3c 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -27,6 +27,8 @@ UBOOT_BIN = u-boot.kwb
UBOOT_MAKE_TARGET = $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
UBOOT_BIN = u-boot.ldr
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
+UBOOT_BIN = u-boot-nand.bin
else
UBOOT_BIN = u-boot.bin
endif