summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorNicolas Dechesne <n-dechesne@ti.com>2012-03-18 23:04:51 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 23:50:24 +0200
commit81302ba68569ff62566fe463a4a8ac1a1d12baca (patch)
treebcfd2a4256eb2e0cdd49e20c275a6646347452d5 /boot/uboot
parent7c79537cffbf52ceecd3a46ed5d52211eeefcd1e (diff)
downloadbuildroot-novena-81302ba68569ff62566fe463a4a8ac1a1d12baca.tar.gz
buildroot-novena-81302ba68569ff62566fe463a4a8ac1a1d12baca.zip
uboot: add a new binary format for u-boot.img
For some platforms like OMAP, a new binary format is now being used for u-boot: u-boot.img. It is basically u-boot.bin which has been processed with mkimage. Signed-off-by: Nicolas Dechesne <n-dechesne@ti.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in3
-rw-r--r--boot/uboot/uboot.mk2
2 files changed, 5 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index cb4064804..f83cf4b51 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -83,6 +83,9 @@ choice
config BR2_TARGET_UBOOT_FORMAT_BIN
bool "u-boot.bin"
+config BR2_TARGET_UBOOT_FORMAT_IMG
+ bool "u-boot.img"
+
config BR2_TARGET_UBOOT_FORMAT_NAND_BIN
bool "u-boot-nand.bin"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index f64964c00..31190922f 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -29,6 +29,8 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
UBOOT_BIN = u-boot.ldr
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)
UBOOT_BIN = u-boot-nand.bin
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_IMG),y)
+UBOOT_BIN = u-boot.img
else
UBOOT_BIN = u-boot.bin
endif