summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-18 15:22:13 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-18 15:27:52 +0200
commit7a2fa1f8db5c2e627a4b939862af5f938fcfc359 (patch)
tree493a2520b34487f2c983b69a2f6775784d6ad9cf /boot/uboot
parent1dfc43cced8d30984687950beca6448203fb576d (diff)
downloadbuildroot-novena-7a2fa1f8db5c2e627a4b939862af5f938fcfc359.tar.gz
buildroot-novena-7a2fa1f8db5c2e627a4b939862af5f938fcfc359.zip
uboot-tools: add fw_printenv, rename to uboot-tools
Move fw_printenv / fw_setenv options from the uboot bootloader build to the uboot-mkimage package, and rename it to uboot-tools. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in5
-rw-r--r--boot/uboot/uboot.mk19
2 files changed, 0 insertions, 24 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 070533efd..a0b2bfc87 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -91,11 +91,6 @@ config BR2_TARGET_UBOOT_FORMAT_LDR
endchoice
-config BR2_TARGET_UBOOT_TOOL_ENV
- bool "fw_printenv tool in target"
- help
- Install fw_printenv / fw_setenv tools in target.
-
menuconfig BR2_TARGET_UBOOT_NETWORK
bool "Network Settings"
default y
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 0610e4c9d..142557995 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -78,35 +78,16 @@ define UBOOT_CONFIGURE_CMDS
@echo "#endif /* __BR2_ADDED_CONFIG_H */" >> $(@D)/include/config.h
endef
-ifeq ($(BR2_TARGET_UBOOT_TOOL_ENV),y)
-define UBOOT_BUILD_TARGET_ENV_UTILS
- $(TARGET_CONFIGURE_OPTS) $(MAKE) HOSTCC="$(TARGET_CC)" -C $(@D) env
-endef
-endif
-
define UBOOT_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(UBOOT_CONFIGURE_OPTS) \
$(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS) \
$(UBOOT_MAKE_TARGET)
- $(UBOOT_BUILD_TARGET_ENV_UTILS)
endef
define UBOOT_INSTALL_IMAGES_CMDS
cp -dpf $(@D)/$(UBOOT_BIN) $(BINARIES_DIR)/
endef
-ifeq ($(BR2_TARGET_UBOOT_TOOL_ENV),y)
-define UBOOT_INSTALL_TARGET_ENV_UTILS
- $(INSTALL) -m 0755 -D $(@D)/tools/env/fw_printenv \
- $(TARGET_DIR)/usr/sbin/fw_printenv
- ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
-endef
-endif
-
-define UBOOT_INSTALL_TARGET_CMDS
- $(UBOOT_INSTALL_TARGET_ENV_UTILS)
-endef
-
$(eval $(call GENTARGETS,boot,uboot))
ifeq ($(BR2_TARGET_UBOOT),y)