summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:33:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:59:03 +0200
commit32a0454d3c495b12824ef4a0d0341237302d148a (patch)
tree9acc870d089b0028cecdfb1846b828ae4bd38910 /boot/uboot
parentf9686563b4fd3eed22e26105f7c440f0b74fcac1 (diff)
parentdafa32b3bd75e9d155d075c796fa5b0ecbb9b11b (diff)
downloadbuildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.tar.gz
buildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.zip
Merge branch 'next'
Conflicts: package/e2fsprogs/e2fsprogs.mk package/libfuse/libfuse.mk package/multimedia/mpd/mpd.mk package/smartmontools/smartmontools.mk Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in8
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index afc2f917a..900fac7fc 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -79,6 +79,14 @@ endif
choice
prompt "U-Boot binary format"
+ default BR2_TARGET_UBOOT_FORMAT_BIN
+
+config BR2_TARGET_UBOOT_FORMAT_AIS
+ bool "u-boot.ais"
+ help
+ AIS (Application Image Script) is a format defined by TI.
+ It is required to load code/data on OMAP-L1 processors.
+ u-boot.ais contains U-Boot with the SPL support.
config BR2_TARGET_UBOOT_FORMAT_BIN
bool "u-boot.bin"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index f3810c247..619f2e1e3 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -28,6 +28,9 @@ endif
ifeq ($(BR2_TARGET_UBOOT_FORMAT_KWB),y)
UBOOT_BIN = u-boot.kwb
UBOOT_MAKE_TARGET = $(UBOOT_BIN)
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_AIS),y)
+UBOOT_BIN = u-boot.ais
+UBOOT_MAKE_TARGET = $(UBOOT_BIN)
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_LDR),y)
UBOOT_BIN = u-boot.ldr
else ifeq ($(BR2_TARGET_UBOOT_FORMAT_NAND_BIN),y)