summaryrefslogtreecommitdiffstats
path: root/boot/uboot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-07-11 22:46:12 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-11 23:41:00 +0200
commit29679495b8f247171a741f11c666cbb2ae254cd7 (patch)
tree28d5998694dc82aec7ceba12a45f6026b548370d /boot/uboot
parent205fb19cdb475b0b56e675f53bdeca17deb98fbe (diff)
downloadbuildroot-novena-29679495b8f247171a741f11c666cbb2ae254cd7.tar.gz
buildroot-novena-29679495b8f247171a741f11c666cbb2ae254cd7.zip
u-boot: allow specification of custom Git repo as source
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/uboot')
-rw-r--r--boot/uboot/Config.in14
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 17 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index aada346e7..dbd4f34df 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -34,6 +34,9 @@ config BR2_TARGET_UBOOT_2010_03
config BR2_TARGET_UBOOT_CUSTOM_TARBALL
bool "Custom tarball"
+config BR2_TARGET_UBOOT_CUSTOM_GIT
+ bool "Custom Git repository"
+
endchoice
if BR2_TARGET_UBOOT_CUSTOM_TARBALL
@@ -51,6 +54,7 @@ config BR2_TARGET_UBOOT_VERSION
default "2010.06" if BR2_TARGET_UBOOT_2010_06
default "2010.03" if BR2_TARGET_UBOOT_2010_03
default "custom" if BR2_TARGET_UBOOT_CUSTOM_TARBALL
+ default $BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION if BR2_TARGET_UBOOT_CUSTOM_GIT
config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
string "custom patch dir"
@@ -61,6 +65,16 @@ config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
Most users may leave this empty
+if BR2_TARGET_UBOOT_CUSTOM_GIT
+
+config BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL
+ string "URL of custom Git repository"
+
+config BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION
+ string "Custom Git version"
+
+endif
+
choice
prompt "U-Boot binary format"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index dfa012a8f..e87727b5d 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -13,6 +13,9 @@ ifeq ($(UBOOT_VERSION),custom)
UBOOT_TARBALL = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_TARBALL_LOCATION))
UBOOT_SITE = $(dir $(UBOOT_TARBALL))
UBOOT_SOURCE = $(notdir $(UBOOT_TARBALL))
+else ifeq ($(BR2_TARGET_UBOOT_CUSTOM_GIT),y)
+UBOOT_SITE = $(call qstrip,$(BR2_TARGET_UBOOT_CUSTOM_GIT_REPO_URL))
+UBOOT_SITE_METHOD = git
else
# Handle stable official U-Boot versions
UBOOT_SITE = ftp://ftp.denx.de/pub/u-boot