summaryrefslogtreecommitdiffstats
path: root/boot/syslinux
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-01-23 21:19:29 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-24 12:59:47 +0100
commit9baaa5b4a39145f4cc64c6bba1a6aa8cec48f00a (patch)
tree4a14c4da71e8a59e4280daa85be0064a24a28046 /boot/syslinux
parentafb6e3ed52142ef8d9450a743f9487c4fedf9a0f (diff)
downloadbuildroot-novena-9baaa5b4a39145f4cc64c6bba1a6aa8cec48f00a.tar.gz
buildroot-novena-9baaa5b4a39145f4cc64c6bba1a6aa8cec48f00a.zip
syslinux: add support for host-install
This makes it possible to build the syslinux/extlinux installer, so a bootable USB drive, CompactFlash or SD card can be created by a user script. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/syslinux')
-rw-r--r--boot/syslinux/syslinux.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index da30d5a20..3e89bdfca 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -26,4 +26,18 @@ define SYSLINUX_INSTALL_IMAGES_CMDS
done
endef
+
+define HOST_SYSLINUX_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_SYSLINUX_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) INSTALLROOT=$(HOST_DIR) install
+endef
+
+define HOST_SYSLINUX_CLEAN_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) clean
+endef
+
$(eval $(call GENTARGETS))
+$(eval $(call GENTARGETS,host))