summaryrefslogtreecommitdiffstats
path: root/boot/at91dataflashboot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-06-14 22:59:14 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-06-14 23:06:37 +0200
commitd2f6fcd1b4e0cffd621f2ceec347536e4322e8a4 (patch)
tree0ff0d98dc85632f0ac44061fc841963a0a19d0c0 /boot/at91dataflashboot
parent1e17790cf282bd5d3cb8e3d419c331f991134742 (diff)
downloadbuildroot-novena-d2f6fcd1b4e0cffd621f2ceec347536e4322e8a4.tar.gz
buildroot-novena-d2f6fcd1b4e0cffd621f2ceec347536e4322e8a4.zip
at91dataflashboot: fix patch target
Touch destination file so the patch target isn't rerun for every invocation. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot/at91dataflashboot')
-rw-r--r--boot/at91dataflashboot/at91dataflashboot.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/boot/at91dataflashboot/at91dataflashboot.mk b/boot/at91dataflashboot/at91dataflashboot.mk
index d11f842d8..32591f79f 100644
--- a/boot/at91dataflashboot/at91dataflashboot.mk
+++ b/boot/at91dataflashboot/at91dataflashboot.mk
@@ -16,11 +16,12 @@ $(DL_DIR)/$(DATAFLASHBOOT_SOURCE):
$(DATAFLASHBOOT_DIR)/.unpacked: $(DL_DIR)/$(DATAFLASHBOOT_SOURCE)
mkdir -p $(@D)
$(BZCAT) $(DL_DIR)/$(DATAFLASHBOOT_SOURCE) | tar $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
- touch $(DATAFLASHBOOT_DIR)/.unpacked
+ touch $@
$(DATAFLASHBOOT_DIR)/.patched: $(DATAFLASHBOOT_DIR)/.unpacked
toolchain/patch-kernel.sh $(@D) boot/at91dataflashboot \
at91dataflashboot-$(DATAFLASHBOOT_VERSION)-\*.patch
+ touch $@
$(DATAFLASHBOOT_DIR)/$(DATAFLASHBOOT_BINARY): $(DATAFLASHBOOT_DIR)/.patched
ls $(DATAFLASHBOOT_DIR)/.unpacked