summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-11-12 10:08:28 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 12:06:40 -0800
commitebcfa987df4095a7805ff124ab648fb607c89215 (patch)
treed8fdfb8438bb9323f78d2dd9ce288d131ded957d /Makefile
parentcc6da8b28ef6b6dde2eaaaf40d21f366508221ad (diff)
downloadbuildroot-novena-ebcfa987df4095a7805ff124ab648fb607c89215.tar.gz
buildroot-novena-ebcfa987df4095a7805ff124ab648fb607c89215.zip
pkg-infra: introduce errors for legacy API
As discussed in the BR developer days, we want to be more strict about API changes in buildroot. I.e., we want to make it less likely that a user's customizations break down after upgrading buildroot. A first step is to make sure that the user is warned about API changes. This patch introduces Makefile.legacy and Config.in.legacy, which will issue clear error messages for such situations. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 21aa054a9..1e257e97e 100644
--- a/Makefile
+++ b/Makefile
@@ -290,6 +290,12 @@ endif
all: world
+# Include legacy before the other things, because package .mk files
+# may rely on it.
+ifneq ($(BR2_DEPRECATED),y)
+include Makefile.legacy
+endif
+
include package/Makefile.in
include support/dependencies/dependencies.mk
@@ -762,4 +768,3 @@ print-version:
include docs/manual/manual.mk
.PHONY: $(noconfig_targets)
-