summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-04-05 10:44:54 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-05 10:44:54 +0200
commitcd61ea772be42338b733ac750ba653be19728e9f (patch)
tree0df54353987351b9de82f97d08981c62663b7999 /Makefile
parentf94830d0e5a409b2e2dc30a4e002c180fe09ec4e (diff)
downloadbuildroot-novena-cd61ea772be42338b733ac750ba653be19728e9f.tar.gz
buildroot-novena-cd61ea772be42338b733ac750ba653be19728e9f.zip
Makefile: out-of-tree fix for uclibc 0.9.31
Strangely enough O is still passed to submakes with MAKEOVERRIDES (with make 3.81 atleast), the only thing that changes is the output of the origin function (command line -> environment). Unfortunately some packages don't look at origin (E.G. uClibc 0.9.31+) To really make O go away, we have to override it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b746934f9..b47c0b0dd 100644
--- a/Makefile
+++ b/Makefile
@@ -230,6 +230,12 @@ else
# forwards command line variable definitions those packages get very
# confused. Fix this by telling make to not do so
MAKEOVERRIDES =
+# strangely enough O is still passed to submakes with MAKEOVERRIDES
+# (with make 3.81 atleast), the only thing that changes is the output
+# of the origin function (command line -> environment).
+# Unfortunately some packages don't look at origin (E.G. uClibc 0.9.31+)
+# To really make O go away, we have to override it.
+override O:=$(O)
endif
# bash prints the name of the directory on 'cd <dir>' if CDPATH is