summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-15 09:47:49 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-15 09:47:49 +0000
commitc2fc93bcf2c405211e786372fcee63680b6ba9ed (patch)
treec53f70a2d552b394390418963ee1cf82a55bd2b4 /Makefile
parent8118da144991ab7004522b1e16f06675cc31b3ec (diff)
downloadbuildroot-novena-c2fc93bcf2c405211e786372fcee63680b6ba9ed.tar.gz
buildroot-novena-c2fc93bcf2c405211e786372fcee63680b6ba9ed.zip
Remove fakeroot files after use to avoid rerun
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 89e6caef1..fabc3a81f 100644
--- a/Makefile
+++ b/Makefile
@@ -199,6 +199,8 @@ include package/*/*.mk
# target stuff is last so it can override anything else
include target/Makefile.in
+TARGETS+=erase-fakeroots
+
TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
@@ -255,6 +257,8 @@ $(PROJECT_BUILD_DIR)/.root: $(TARGET_DIR)
fi;
touch $@
+erase-fakeroots:
+ rm -f $(STAGING_DIR)/.fakeroot*
source: $(TARGETS_SOURCE) $(HOST_SOURCE)