summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-11-17 11:21:23 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-11-17 11:21:23 +0000
commit870cb9e826634f5a59e32866ec13c3e9869e594f (patch)
tree21a647a0bca4097c934187e6dbadf49228325550 /Makefile
parent2235df97347f72a008ba1bd7a743729d0ad75f0d (diff)
downloadbuildroot-novena-870cb9e826634f5a59e32866ec13c3e9869e594f.tar.gz
buildroot-novena-870cb9e826634f5a59e32866ec13c3e9869e594f.zip
- check if busybox' Rules.mak exists.
- add target dirs to ensure that all required dirs do exist so make busybox-menuconfig works in a pristine checkout.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 71d2ded46..0e21be0e6 100644
--- a/Makefile
+++ b/Makefile
@@ -75,9 +75,10 @@ TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
-world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
+dirs: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR)
+world: dirs $(TARGET_DIR) $(TARGETS)
-.PHONY: all world clean dirclean distclean source $(TARGETS) \
+.PHONY: all world dirs clean dirclean distclean source $(TARGETS) \
$(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)