summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-03-07 20:26:50 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-08 22:56:33 +0100
commitf044e03776652d4f822c2f3787142bda34364965 (patch)
tree51209efd567818919a10817e9364f457ce54b970
parent7ea11dafff37c5403432f691cf3c46d1d5566e46 (diff)
downloadbuildroot-novena-f044e03776652d4f822c2f3787142bda34364965.tar.gz
buildroot-novena-f044e03776652d4f822c2f3787142bda34364965.zip
ccache: set COMPILERCHECK to 'none'
This allows ccache to re-use its cache contents even if the compiler binary mtime has changed. It is the simplest approach to solve this problem, and it works for the internal, external and crosstool-ng toolchain backends. Of course, it leaves the user responsible for invalidating the cache when necessary, but there doesn't seem to be a real good solution that allows both to: 1/ keep the cache contents accross builds and re-use it and 2/ invalidate the cache automatically when the compiler chances in an incompatible way. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Config.in7
-rw-r--r--package/ccache/ccache.mk12
2 files changed, 17 insertions, 2 deletions
diff --git a/Config.in b/Config.in
index 8579a63b1..2002996fe 100644
--- a/Config.in
+++ b/Config.in
@@ -191,6 +191,13 @@ config BR2_CCACHE
up future builds. The cache is stored in
$HOME/.buildroot-ccache.
+ Note that Buildroot does not try to invalidate the cache
+ contents when the compiler changes in an incompatible
+ way. Therefore, if you make a change to the compiler version
+ and/or configuration, you are responsible for purging the
+ ccache cache by removing the $HOME/.buildroot-ccache
+ directory.
+
config BR2_DEPRECATED
bool "Show packages that are deprecated or obsolete"
help
diff --git a/package/ccache/ccache.mk b/package/ccache/ccache.mk
index 393989f54..f71376ee8 100644
--- a/package/ccache/ccache.mk
+++ b/package/ccache/ccache.mk
@@ -25,10 +25,18 @@ HOST_CCACHE_CONF_ENV = \
# has zero dependency besides the C library.
HOST_CCACHE_CONF_OPT += ccache_cv_zlib_1_2_3=no
-# We directly hardcode the cache location into the binary, as it is
-# much easier to handle than passing an environment variable.
+# We directly hardcode configuration into the binary, as it is much
+# easier to handle than passing an environment variable. Our
+# configuration is:
+# - the cache location
+# - the fact that ccache shouldn't use the compiler binary mtime to
+# - detect a change in the compiler, because in the context of
+# - Buildroot, that completely defeats the purpose of ccache. Of
+# - course, that leaves the user responsible for purging its cache
+# - when the compiler changes.
define HOST_CCACHE_FIX_CCACHE_DIR
sed -i 's,getenv("CCACHE_DIR"),"$(CCACHE_CACHE_DIR)",' $(@D)/ccache.c
+ sed -i 's,getenv("CCACHE_COMPILERCHECK"),"none",' $(@D)/ccache.c
endef
HOST_CCACHE_POST_CONFIGURE_HOOKS += \