summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-10-31 17:35:10 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-03 23:26:45 +0100
commite5e8fae892036360f399ed034463716f31bfd59f (patch)
tree42e0fb498800bd8f793c3025ed28b9c4ee6ff7cd
parent2d239bbe2771aa9f8ec5e02241a93c63195489a7 (diff)
downloadbuildroot-novena-e5e8fae892036360f399ed034463716f31bfd59f.tar.gz
buildroot-novena-e5e8fae892036360f399ed034463716f31bfd59f.zip
Makefile: move version string from Config.in into Makefile
This re-instates writing the version string in .config headers, and no longer provides it as a kconfig symbol in .config (it is now a variable in the Makefile, and in the environment). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Config.in2
-rw-r--r--Makefile8
-rw-r--r--package/config/confdata.c4
-rw-r--r--package/config/patches/01-kconfig-kernel-to-buildroot.patch12
4 files changed, 16 insertions, 10 deletions
diff --git a/Config.in b/Config.in
index 0f8ddf4fa..81072962a 100644
--- a/Config.in
+++ b/Config.in
@@ -8,7 +8,7 @@ config BR2_HAVE_DOT_CONFIG
config BR2_VERSION
string
- default "2010.11-git"
+ option env="BR2_VERSION"
source "target/Config.in.arch"
source "target/device/Config.in"
diff --git a/Makefile b/Makefile
index 3780fe6e2..8d53778b3 100644
--- a/Makefile
+++ b/Makefile
@@ -23,6 +23,9 @@
# You shouldn't need to mess with anything beyond this point...
#--------------------------------------------------------------
+# Set and export the version string
+export BR2_VERSION:=2010.11-git
+
# This top-level Makefile can *not* be executed in parallel
.NOTPARALLEL:
@@ -631,9 +634,8 @@ help:
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
-release:
- OUT=buildroot-$$(grep -A2 BR2_VERSION $(CONFIG_CONFIG_IN)|grep default|cut -f2 -d\"); \
- git archive --format=tar --prefix=$$OUT/ master|gzip -9 >$$OUT.tar.gz
+release: OUT=buildroot-$(BR2_VERSION)
+ git archive --format=tar --prefix=$(OUT)/ master|gzip -9 >$(OUT).tar.gz
.PHONY: $(noconfig_targets)
diff --git a/package/config/confdata.c b/package/config/confdata.c
index ba1f8a7ed..5cfb6d23a 100644
--- a/package/config/confdata.c
+++ b/package/config/confdata.c
@@ -586,8 +586,10 @@ int conf_write(const char *name)
fprintf(out, _("#\n"
"# Automatically generated make config: don't edit\n"
+ "# Buildroot version: %s\n"
"%s%s"
"#\n"),
+ sym_get_string_value(sym),
use_timestamp ? "# " : "",
use_timestamp ? ctime(&now) : "");
@@ -831,8 +833,10 @@ int conf_write_autoconf(void)
time(&now);
fprintf(out, "#\n"
"# Automatically generated make config: don't edit\n"
+ "# Buildroot version: %s\n"
"# %s"
"#\n",
+ sym_get_string_value(sym),
ctime(&now));
fprintf(tristate, "#\n"
"# Automatically generated - do not edit\n"
diff --git a/package/config/patches/01-kconfig-kernel-to-buildroot.patch b/package/config/patches/01-kconfig-kernel-to-buildroot.patch
index f77a54ca9..9df22d491 100644
--- a/package/config/patches/01-kconfig-kernel-to-buildroot.patch
+++ b/package/config/patches/01-kconfig-kernel-to-buildroot.patch
@@ -69,18 +69,16 @@ Index: config/confdata.c
sym_calc_value(sym);
time(&now);
env = getenv("KCONFIG_NOTIMESTAMP");
-@@ -588,10 +588,8 @@
+@@ -588,7 +588,7 @@
fprintf(out, _("#\n"
"# Automatically generated make config: don't edit\n"
- "# Linux kernel version: %s\n"
++ "# Buildroot version: %s\n"
"%s%s"
"#\n"),
-- sym_get_string_value(sym),
- use_timestamp ? "# " : "",
- use_timestamp ? ctime(&now) : "");
-
-@@ -802,25 +800,23 @@
+ sym_get_string_value(sym),
+@@ -802,25 +802,25 @@
return 1;
}
@@ -91,9 +89,11 @@ Index: config/confdata.c
fprintf(out, "#\n"
"# Automatically generated make config: don't edit\n"
- "# Linux kernel version: %s\n"
++ "# Buildroot version: %s\n"
"# %s"
"#\n",
- sym_get_string_value(sym), ctime(&now));
++ sym_get_string_value(sym),
+ ctime(&now));
fprintf(tristate, "#\n"
"# Automatically generated - do not edit\n"