summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-05 21:26:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-22 21:20:27 +0200
commitdc4d5647a528b366d88d4c6f94405c12a1aa0ebf (patch)
treec76fcc774024439a97f071f8dfd3a4df240a4f01
parentdcc08e84a5e94e7ffaf52ec4374821e56bb20a34 (diff)
downloadbuildroot-novena-dc4d5647a528b366d88d4c6f94405c12a1aa0ebf.tar.gz
buildroot-novena-dc4d5647a528b366d88d4c6f94405c12a1aa0ebf.zip
linux: Add dependency on host-module-init-tools
In order to not depend on module init tools being installed on the development environment of the Buildroot user, let's build module init tools for the host. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--linux/linux.mk2
-rw-r--r--package/module-init-tools/module-init-tools.mk2
2 files changed, 3 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 3e91ecaba..8b83e3066 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -111,7 +111,7 @@ $(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
fi
$(Q)touch $@
-linux26: $(LINUX26_DEPENDENCIES) $(LINUX26_DIR)/.stamp_installed
+linux26: host-module-init-tools $(LINUX26_DEPENDENCIES) $(LINUX26_DIR)/.stamp_installed
ifeq ($(BR2_LINUX_KERNEL),y)
TARGETS+=linux26
diff --git a/package/module-init-tools/module-init-tools.mk b/package/module-init-tools/module-init-tools.mk
index 3e8b06bde..ea7c014dc 100644
--- a/package/module-init-tools/module-init-tools.mk
+++ b/package/module-init-tools/module-init-tools.mk
@@ -17,3 +17,5 @@ MODULE_INIT_TOOLS_AUTORECONF=YES
HOST_MODULE_INIT_TOOLS_AUTORECONF=YES
$(eval $(call AUTOTARGETS,package,module-init-tools))
+$(eval $(call AUTOTARGETS,package,module-init-tools,host))
+