summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-11-12 10:08:29 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 12:06:56 -0800
commitcc1cd3b267212c0e932db4855ff7c1afe0b45e67 (patch)
tree5dc69b06c6c213509054e2c5de3fb9454a81ff85
parentebcfa987df4095a7805ff124ab648fb607c89215 (diff)
downloadbuildroot-novena-cc1cd3b267212c0e932db4855ff7c1afe0b45e67.tar.gz
buildroot-novena-cc1cd3b267212c0e932db4855ff7c1afe0b45e67.zip
legacy: move old GENTARGETS macros to Makefile.legacy
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Makefile.legacy7
-rw-r--r--package/Makefile.in6
2 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.legacy b/Makefile.legacy
index 2e015a1e3..c8b568d75 100644
--- a/Makefile.legacy
+++ b/Makefile.legacy
@@ -11,3 +11,10 @@
ifeq ($(BR2_LEGACY),y)
$(error "You have legacy configuration in your .config! Please check your configuration.")
endif
+
+#
+# Legacy options from 2012.05
+#
+GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
+AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
+CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
diff --git a/package/Makefile.in b/package/Makefile.in
index 9fdc74599..2dd81c72c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -305,12 +305,6 @@ else
SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
endif
-# Warn if a package uses the deprecated GENTARGETS macros. This can be
-# removed again for BR-2012.11.
-GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
-AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
-CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
-
include package/pkg-utils.mk
include package/pkg-download.mk
include package/pkg-autotools.mk