summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-13 22:51:37 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-12-13 22:51:37 +0000
commitb3d0f31bdce9d43201be68461296d547be16c139 (patch)
treede9531ff33d6d61e053f32981634ee35fa39ca45
parent189ccbaf529332af60704ce4b542950287c1241a (diff)
downloadbuildroot-novena-b3d0f31bdce9d43201be68461296d547be16c139.tar.gz
buildroot-novena-b3d0f31bdce9d43201be68461296d547be16c139.zip
- make sure to agree on the installation CONFIG_PREFIX
-rw-r--r--package/busybox/busybox.mk2
-rw-r--r--target/device/x86/i386/busybox.config2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 0ac97489d..c06482e31 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -71,6 +71,8 @@ ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_2_2_1)),y)
$(BUSYBOX_DIR)/.config ;
endif
ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
+ $(SED) s,^CONFIG_PREFIX=.*,CONFIG_PREFIX=\"$(TARGET_DIR)\", \
+ $(BUSYBOX_DIR)/.config ;
$(SED) s,^CROSS_COMPILER_PREFIX=.*,CROSS_COMPILER_PREFIX=\"$(TARGET_CROSS)\", \
$(BUSYBOX_DIR)/.config ;
$(SED) s,^PREFIX=.*,CROSS_COMPILER_PREFIX=\"$(TARGET_CROSS)\", \
diff --git a/target/device/x86/i386/busybox.config b/target/device/x86/i386/busybox.config
index d1b8a88d7..73bd5336b 100644
--- a/target/device/x86/i386/busybox.config
+++ b/target/device/x86/i386/busybox.config
@@ -57,7 +57,7 @@ CONFIG_DEBUG_YANK_SUSv2=y
CONFIG_INSTALL_APPLET_SYMLINKS=y
# CONFIG_INSTALL_APPLET_HARDLINKS is not set
# CONFIG_INSTALL_APPLET_DONT is not set
-PREFIX="./_install"
+CONFIG_PREFIX="./_install"
#
# Busybox Library Tuning