summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-24 22:37:40 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-10 21:05:12 +0200
commitafd77256c9914663af7684792051fee74c610fb9 (patch)
tree71cbdd9d3a2829188e7b1f38b71e43192d914154
parent649b5b92509dba021ed47ef4c04f358de83ba36f (diff)
downloadbuildroot-novena-afd77256c9914663af7684792051fee74c610fb9.tar.gz
buildroot-novena-afd77256c9914663af7684792051fee74c610fb9.zip
yaboot: drop support
Yaboot does not build, hasn't been updated since a long time, and isn't very common these days on embedded PowerPC platforms. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--boot/Config.in1
-rw-r--r--boot/yaboot/Config.in5
-rw-r--r--boot/yaboot/yaboot.mk44
3 files changed, 0 insertions, 50 deletions
diff --git a/boot/Config.in b/boot/Config.in
index 6f2796f0c..78ff82c96 100644
--- a/boot/Config.in
+++ b/boot/Config.in
@@ -3,7 +3,6 @@ menu "Bootloaders"
source "boot/grub/Config.in"
source "boot/grub2/Config.in"
source "boot/syslinux/Config.in"
-source "boot/yaboot/Config.in"
source "boot/u-boot/Config.in"
source "boot/at91bootstrap/Config.in"
source "boot/at91dataflashboot/Config.in"
diff --git a/boot/yaboot/Config.in b/boot/yaboot/Config.in
deleted file mode 100644
index 75da815ab..000000000
--- a/boot/yaboot/Config.in
+++ /dev/null
@@ -1,5 +0,0 @@
-config BR2_TARGET_YABOOT
- bool "yaboot"
- depends on BR2_powerpc
- help
- The yaboot bootloader for new world powerpc systems.
diff --git a/boot/yaboot/yaboot.mk b/boot/yaboot/yaboot.mk
deleted file mode 100644
index cbeae5086..000000000
--- a/boot/yaboot/yaboot.mk
+++ /dev/null
@@ -1,44 +0,0 @@
-ifeq ($(ARCH),powerpc)
-
-#############################################################
-#
-# yaboot
-#
-#############################################################
-
-YABOOT_SOURCE:=yaboot-1.3.13.tar.gz
-YABOOT_SITE:=http://penguinppc.org/bootloaders/yaboot
-YABOOT_DIR:=$(BUILD_DIR)/yaboot-1.3.13
-
-$(DL_DIR)/$(YABOOT_SOURCE):
- $(call DOWNLOAD,$(YABOOT_SITE),$(YABOOT_SOURCE))
-
-yaboot-source: $(DL_DIR)/$(YABOOT_SOURCE)
-
-$(YABOOT_DIR)/Makefile: $(DL_DIR)/$(YABOOT_SOURCE)
- $(ZCAT) $(DL_DIR)/$(YABOOT_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- touch -c $(YABOOT_DIR)/Makefile
-
-$(YABOOT_DIR)/second/yaboot: $(YABOOT_DIR)/Makefile
- $(MAKE) -C $(YABOOT_DIR) CROSS=$(TARGET_CROSS)
- touch -c $(YABOOT_DIR)/second/yaboot
-
-yaboot: $(YABOOT_DIR)/second/yaboot
-
-yaboot-clean:
- $(MAKE) -C $(YABOOT_DIR) clean
-
-yaboot-dirclean:
- rm -rf $(YABOOT_DIR)
-
-endif
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_TARGET_YABOOT),y)
-TARGETS+=yaboot
-endif
-