summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-27 12:21:09 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-27 12:21:09 +0000
commita6acb09e2a200f48cedbdd29822875189fe4fbc0 (patch)
tree7b5c1dc13423790605c60501bc0c234a74fd7765
parent7eb4c6a0a9977c5688d499b48b72971b4a4019c8 (diff)
downloadbuildroot-novena-a6acb09e2a200f48cedbdd29822875189fe4fbc0.tar.gz
buildroot-novena-a6acb09e2a200f48cedbdd29822875189fe4fbc0.zip
gtkperf: Adding gtkperf package
Allows some benchmarking of GTK on different targets.
-rw-r--r--package/Config.in1
-rw-r--r--package/gtkperf/Config.in10
-rw-r--r--package/gtkperf/gtkperf.mk15
3 files changed, 26 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 4cef78945..72fd03d3d 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -405,6 +405,7 @@ source "package/alsamixergui/Config.in"
source "package/dillo/Config.in"
source "package/docker/Config.in"
source "package/gqview/Config.in"
+source "package/gtkperf/Config.in"
source "package/leafpad/Config.in"
source "package/midori/Config.in"
source "package/pcmanfm/Config.in"
diff --git a/package/gtkperf/Config.in b/package/gtkperf/Config.in
new file mode 100644
index 000000000..0122b5208
--- /dev/null
+++ b/package/gtkperf/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_GTKPERF
+ bool "gtkperf (performance test for GTK2)"
+ depends on BR2_PACKAGE_LIBGTK2
+ help
+ GtkPerf is an application designed to test GTK+ performance.
+ The point is to create common testing platform to run
+ predefined GTK+ widgets
+ e.g. (opening comboboxes, toggling buttons, scrolling text yms.)
+ and this way define the speed of device/platform.
+
diff --git a/package/gtkperf/gtkperf.mk b/package/gtkperf/gtkperf.mk
new file mode 100644
index 000000000..2e733920f
--- /dev/null
+++ b/package/gtkperf/gtkperf.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# GtkPerf
+#
+#############################################################
+GTKPERF_VERSION:=0.40
+GTKPERF_SOURCE:=gtkperf_$(GTKPERF_VERSION).tar.gz
+GTKPERF_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/gtkperf
+GTKPERF_AUTORECONF = NO
+GTKPERF_INSTALL_TARGET = YES
+GTKPERF_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install
+GTKPERF_DEPENDENCIES = libgtk2
+
+$(eval $(call AUTOTARGETS,package,gtkperf))
+