summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-06-07 10:48:45 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-06-07 10:48:45 +0200
commit86bfe7cca9bca292f00f7a41221ae5879f4a5769 (patch)
tree0cb0e7c0557016c81b129ac901cb2f5a429d2cbf
parent484b6dd8a3abccf0be34d1bed3761a8809ba23be (diff)
downloadbuildroot-novena-86bfe7cca9bca292f00f7a41221ae5879f4a5769.tar.gz
buildroot-novena-86bfe7cca9bca292f00f7a41221ae5879f4a5769.zip
manual: github: merge tag/commit ID examples
And reword as suggested by Samuel. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--docs/manual/adding-packages-tips.txt24
1 files changed, 8 insertions, 16 deletions
diff --git a/docs/manual/adding-packages-tips.txt b/docs/manual/adding-packages-tips.txt
index f435add02..8b27c619a 100644
--- a/docs/manual/adding-packages-tips.txt
+++ b/docs/manual/adding-packages-tips.txt
@@ -43,23 +43,15 @@ Packages on github often don't have a download area with release tarballs.
However, it is possible to download tarballs directly from the repository
on github.
-If the package version matches a tag, then this tag should be used to
-identify the version:
-
-------------------------
-FOO_VERSION = v1.0
-FOO_SITE = http://github.com/<user>/<package>/tarball/$(FOO_VERSION)
-------------------------
-
-If the package has no release version, or its version cannot be
-identified using tag, then the SHA1 of the particular commit should be
-used to identify the version (the first 7 characters of the SHA1 are
-enough):
-
------------------------
-FOO_VERSION = 1234567
+FOO_VERSION = v1.0 # tag or (abbreviated) commit ID
FOO_SITE = http://github.com/<user>/<package>/tarball/$(FOO_VERSION)
------------------------
-Note that the name of the tarball is the default +foo-1234567.tar.gz+
-so it is not necessary to specify it in the +.mk+ file.
+.Notes
+- The FOO_VERSION can either be a tag or a commit ID.
+- The tarball name generated by github matches the default one from
+ Buildroot (e.g.: +foo-1234567.tar.gz+),
+ so it is not necessary to specify it in the +.mk+ file.
+- When using a commit ID as version, usually the first 7 characters of
+ the SHA1 are enough.