summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Rosen <jeremy.rosen@openwide.fr>2012-11-06 00:50:12 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-07 09:41:59 +0100
commit7103905fdeb4a92e4572045e16396e53cd1bf749 (patch)
treed1db684ef78202cd827ec8d6b56b6f175db58a38
parentcf76170cc3418f36dd9e4daa2f3d0618ce3dc389 (diff)
downloadbuildroot-novena-7103905fdeb4a92e4572045e16396e53cd1bf749.tar.gz
buildroot-novena-7103905fdeb4a92e4572045e16396e53cd1bf749.zip
add new package fxload
Signed-off-by: Jérémy Rosen <jeremy.rosen@openwide.fr> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Config.in1
-rw-r--r--package/fxload/Config.in9
-rw-r--r--package/fxload/fxload.mk19
3 files changed, 29 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index e531c417d..bcd1b47b0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -211,6 +211,7 @@ source "package/flashrom/Config.in"
source "package/fconfig/Config.in"
source "package/fis/Config.in"
source "package/fmtools/Config.in"
+source "package/fxload/Config.in"
source "package/gadgetfs-test/Config.in"
source "package/gdisk/Config.in"
source "package/gpsd/Config.in"
diff --git a/package/fxload/Config.in b/package/fxload/Config.in
new file mode 100644
index 000000000..ac190f043
--- /dev/null
+++ b/package/fxload/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_FXLOAD
+ bool "fxload"
+ help
+ This program is conveniently able to download firmware into FX, FX2,
+ and FX2LP EZ-USB devices, as well as the original AnchorChips EZ-USB.
+ It is intended to be invoked by hotplug scripts when the unprogrammed
+ device appears on the bus.
+
+ http://sourceforge.net/projects/linux-hotplug/
diff --git a/package/fxload/fxload.mk b/package/fxload/fxload.mk
new file mode 100644
index 000000000..1b5e8c748
--- /dev/null
+++ b/package/fxload/fxload.mk
@@ -0,0 +1,19 @@
+#############################################################
+#
+# fxload
+#
+#############################################################
+FXLOAD_VERSION = 2008_10_13
+FXLOAD_SITE = http://downloads.sourceforge.net/project/linux-hotplug/fxload/$(FXLOAD_VERSION)
+FXLOAD_LICENSE = GPLv2+
+FXLOAD_LICENSE_FILE = COPYING
+
+define FXLOAD_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
+endef
+
+define FXLOAD_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) prefix=$(TARGET_DIR) -C $(@D) install
+endef
+
+$(eval $(generic-package))