summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-20 17:26:59 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-09-20 17:26:59 +0000
commit7025afd93c624585b948a1f47903168c2d340256 (patch)
treeed10512bc468ee5b8bfdceb427f3cc094815c9ac
parent5037c9e6131dd0d2a889d8dfe0d8eed1617618af (diff)
downloadbuildroot-novena-7025afd93c624585b948a1f47903168c2d340256.tar.gz
buildroot-novena-7025afd93c624585b948a1f47903168c2d340256.zip
- Reset flags, packages are usually built with -O2 otherwise.
Packages that need to pass additional CFLAGS in their .mk have to do something like this: ...configure $(foreach i,$(foo_CFLAGS),CFLAGS+=$$i) --prefix=...
-rw-r--r--package/Makefile.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 17f3e9899..397f57669 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -136,6 +136,7 @@ TARGET_CONFIGURE_OPTS=PATH=$(TARGET_PATH) \
GCC="$(TARGET_CROSS)gcc $(TARGET_CFLAGS)" \
CXX="$(TARGET_CROSS)g++ $(TARGET_CFLAGS)" \
CPP="$(TARGET_CROSS)cpp $(TARGET_CFLAGS)" \
+ CFLAGS="" CXXFLAGS="" FFLAGS="" \
RANLIB=$(TARGET_CROSS)ranlib \
STRIP=$(TARGET_CROSS)strip \
OBJCOPY=$(TARGET_CROSS)objcopy \
@@ -205,6 +206,18 @@ else
BR2_AC_CV_C_BIGENDIAN=ac_cv_c_bigendian=no
endif
+# Does malloc return live pointer for malloc(0) ?
+ifeq ($(MALLOC_GLIBC_COMPAT),y)
+BR2_AC_CV_FUNC_MALLOC_0_NONNULL=ac_cv_func_malloc_0_nonnull=yes \
+ gl_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
+else
+BR2_AC_CV_FUNC_MALLOC_0_NONNULL=ac_cv_func_malloc_0_nonnull=no \
+ gl_cv_func_malloc_0_nonnull=no \
+ ac_cv_func_realloc_0_nonnull=no
+endif
+
+
TARGET_CONFIGURE_ARGS= \
$(BR2_AC_CV_TRAP_CHECK) \
ac_cv_func_mmap_fixed_mapped=yes \