summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-08-10 20:58:14 +0000
committerEric Andersen <andersen@codepoet.org>2006-08-10 20:58:14 +0000
commit5cd18319f8a4335ae2f8a986b20f4fae7099b48e (patch)
treea5d17fe3e9a6d55c95bccd4e48617b12bd63367c
parent28e220f7a06689ca59a440abd2e5046ff2fac46e (diff)
downloadbuildroot-novena-5cd18319f8a4335ae2f8a986b20f4fae7099b48e.tar.gz
buildroot-novena-5cd18319f8a4335ae2f8a986b20f4fae7099b48e.zip
comparing $(ARCH) vs i.e. i386 isn't going to work when ARCH=i486 etc.
Need to instead compare vs BR2_i386 and friends.
-rw-r--r--package/portage/portage.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/portage/portage.mk b/package/portage/portage.mk
index 94fd1b455..38552b31e 100644
--- a/package/portage/portage.mk
+++ b/package/portage/portage.mk
@@ -18,22 +18,22 @@ SANDBOX_CAT:=$(PORTAGE_CAT)
SANDBOX_DIR:=$(BUILD_DIR)/sandbox-$(SANDBOX_VERSION)
SANDBOX_TARGET_BINARY:=usr/bin/sandbox
-ifeq ($(ARCH),cris)
+ifeq ($(BR2_cris),y)
PORTAGE_ARCH:=x86
endif
-ifeq ($(ARCH), mipsel)
+ifeq ($(BR2_mipsel),y)
PORTAGE_ARCH:=mips
endif
-ifeq ($(ARCH), powerpc)
+ifeq ($(BR2_powerpc),y)
PORTAGE_ARCH:=ppc
endif
-ifeq ($(ARCH),sh4)
+ifeq ($(BR2_sh4),y)
PORTAGE_ARCH:=sh
endif
-ifeq ($(ARCH),sh64)
+ifeq ($(BR2_sh64),y)
PORTAGE_ARCH:=sh
endif
-ifeq ($(ARCH), i386)
+ifeq ($(BR2_i386),y)
PORTAGE_ARCH:=x86
endif
ifeq ($(PORTAGE_ARCH),)