summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-19 23:32:33 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-19 23:32:33 +0000
commit3c567e64660209d140869fa0a448e11ed5031cd6 (patch)
tree3a84113de089ad5887fa004a7cccf365aee8e1b3
parented96d7f92cd5ef65eb56dc95ed0df44b086e93ee (diff)
downloadbuildroot-novena-3c567e64660209d140869fa0a448e11ed5031cd6.tar.gz
buildroot-novena-3c567e64660209d140869fa0a448e11ed5031cd6.zip
Add support for BUILDROOT_DL_DIR environment variable, overriding DL_DIR
-rw-r--r--Makefile3
-rw-r--r--docs/buildroot.html22
2 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b9e4cd264..c1df6a303 100644
--- a/Makefile
+++ b/Makefile
@@ -37,6 +37,9 @@ noconfig_targets := menuconfig config oldconfig randconfig \
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-include $(TOPDIR).config
endif
+ifneq ($(BUILDROOT_DL_DIR),)
+BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
+endif
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands
diff --git a/docs/buildroot.html b/docs/buildroot.html
index c496b8db4..4b1e9005c 100644
--- a/docs/buildroot.html
+++ b/docs/buildroot.html
@@ -779,6 +779,28 @@ mips-linux-gcc -o foo foo.c
toolchain and the target filesystem with exactly the same
versions. </p>
+ <p>If you maintain several buildroot trees, it might be better to have
+ a shared download location. This can be accessed by creating a symbolic link
+ from the <code>dl</code> directory to the shared download location. </p>
+
+ <p>I.E:</p>
+
+<pre>
+ln -s &lt;shared download location&gt; dl
+</pre>
+
+ <p>Another way of accessing a shared download location is to
+ create the <code>BUILDROOT_DL_DIR</code> environment variable.
+ If this is set, then the value of DL_DIR in the project is
+ overridden. The following line should be added to
+ <code>&quot;~/.bashrc&quot;</code>. <p>
+
+<pre>
+export BUILDROOT_DL_DIR &lt;shared download location&gt;
+</pre>
+
+
+
<h2><a name="add_software" id="add_software"></a>Extending Buildroot with
more software</h2>