summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-02-06 18:17:08 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-02-06 18:17:08 +0000
commit3c28ac08814b8640ccf1584b9c24e7adfed65cee (patch)
tree94d1f0ad351d1c3f81b24d741eddda648261d959
parent821eb62d994cf0dc53d278bca63d6c66e038a065 (diff)
downloadbuildroot-novena-3c28ac08814b8640ccf1584b9c24e7adfed65cee.tar.gz
buildroot-novena-3c28ac08814b8640ccf1584b9c24e7adfed65cee.zip
Fix building of gettext/libintl when using an external toolchain.
-rw-r--r--package/dbus-glib/dbus-glib-libintl.patch12
-rw-r--r--package/gettext/gettext.mk5
-rw-r--r--package/hal/hal06-libintl.patch24
3 files changed, 41 insertions, 0 deletions
diff --git a/package/dbus-glib/dbus-glib-libintl.patch b/package/dbus-glib/dbus-glib-libintl.patch
new file mode 100644
index 000000000..1baa94b0c
--- /dev/null
+++ b/package/dbus-glib/dbus-glib-libintl.patch
@@ -0,0 +1,12 @@
+diff -ur dbus-glib-0.72/dbus/Makefile.in dbus-glib-0.72-patched/dbus/Makefile.in
+--- dbus-glib-0.72/dbus/Makefile.in 2006-10-25 16:14:31.000000000 -0500
++++ dbus-glib-0.72-patched/dbus/Makefile.in 2007-01-17 08:37:22.000000000 -0600
+@@ -493,7 +493,7 @@
+ done
+ dbus-binding-tool$(EXEEXT): $(dbus_binding_tool_OBJECTS) $(dbus_binding_tool_DEPENDENCIES)
+ @rm -f dbus-binding-tool$(EXEEXT)
+- $(LINK) $(dbus_binding_tool_LDFLAGS) $(dbus_binding_tool_OBJECTS) $(dbus_binding_tool_LDADD) $(LIBS)
++ $(LINK) $(dbus_binding_tool_LDFLAGS) $(dbus_binding_tool_OBJECTS) $(dbus_binding_tool_LDADD) $(LIBS) $(INTLLIBS)
+ dbus-glib-test$(EXEEXT): $(dbus_glib_test_OBJECTS) $(dbus_glib_test_DEPENDENCIES)
+ @rm -f dbus-glib-test$(EXEEXT)
+ $(LINK) $(dbus_glib_test_LDFLAGS) $(dbus_glib_test_OBJECTS) $(dbus_glib_test_LDADD) $(LIBS)
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index c9b6fb922..d3f331c5c 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -21,6 +21,10 @@ $(GETTEXT_DIR)/.unpacked: $(DL_DIR)/$(GETTEXT_SOURCE)
toolchain/patch-kernel.sh $(GETTEXT_DIR) package/gettext/ gettext\*.patch
touch $(GETTEXT_DIR)/.unpacked
+ifeq ($(strip $(BR2_TOOLCHAIN_EXTERNAL)),y)
+IGNORE_EXTERNAL_GETTEXT:=--with-included-gettext
+endif
+
$(GETTEXT_DIR)/.configured: $(GETTEXT_DIR)/.unpacked
(cd $(GETTEXT_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
@@ -95,6 +99,7 @@ $(GETTEXT_DIR)/.configured: $(GETTEXT_DIR)/.unpacked
--mandir=/usr/man \
--infodir=/usr/info \
--disable-libasprintf \
+ $(IGNORE_EXTERNAL_GETTEXT) \
);
touch $(GETTEXT_DIR)/.configured
diff --git a/package/hal/hal06-libintl.patch b/package/hal/hal06-libintl.patch
new file mode 100644
index 000000000..d38124e5c
--- /dev/null
+++ b/package/hal/hal06-libintl.patch
@@ -0,0 +1,24 @@
+diff -ur hal-0.5.8/hald/Makefile.in hal-0.5.8-patched/hald/Makefile.in
+--- hal-0.5.8/hald/Makefile.in 2006-09-11 18:25:30.000000000 -0500
++++ hal-0.5.8-patched/hald/Makefile.in 2007-01-17 08:54:04.000000000 -0600
+@@ -336,7 +336,7 @@
+ osspec.h \
+ property.h property.c
+
+-hald_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -lm @EXPAT_LIB@ $(top_builddir)/hald/$(HALD_BACKEND)/libhald_$(HALD_BACKEND).la
++hald_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ -lm @EXPAT_LIB@ @INTLLIBS@ $(top_builddir)/hald/$(HALD_BACKEND)/libhald_$(HALD_BACKEND).la
+
+ #### Init scripts fun
+ SCRIPT_IN_FILES = haldaemon.in
+diff -ur hal-0.5.8/hald-runner/Makefile.in hal-0.5.8-patched/hald-runner/Makefile.in
+--- hal-0.5.8/hald-runner/Makefile.in 2006-09-11 18:25:30.000000000 -0500
++++ hal-0.5.8-patched/hald-runner/Makefile.in 2007-01-17 08:54:18.000000000 -0600
+@@ -303,7 +303,7 @@
+ @DBUS_CFLAGS@ @GLIB_CFLAGS@
+
+ hald_runner_SOURCES = main.c runner.c runner.h utils.h utils.c
+-hald_runner_LDADD = @GLIB_LIBS@ @DBUS_LIBS@
++hald_runner_LDADD = @GLIB_LIBS@ @DBUS_LIBS@ @INTLLIBS@
+ all: all-am
+
+ .SUFFIXES: