summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-12-08 05:24:59 +0000
committerEric Andersen <andersen@codepoet.org>2006-12-08 05:24:59 +0000
commit3b261a29d552ebd1979982bffa05129e563eb773 (patch)
tree8ed287861cb779db848834734fe5eb01a04ed43a
parentdea2c12405f72c45b5fb5350d45017fb90a8b4d6 (diff)
downloadbuildroot-novena-3b261a29d552ebd1979982bffa05129e563eb773.tar.gz
buildroot-novena-3b261a29d552ebd1979982bffa05129e563eb773.zip
use '/bin/echo -e' to make certain we don't use an unusable /bin/sh builtin
-rwxr-xr-xtoolchain/dependencies/dependencies.sh16
-rw-r--r--toolchain/kernel-headers/kernel-headers.mk6
2 files changed, 11 insertions, 11 deletions
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index 64c10530c..7ec9820a5 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -35,7 +35,7 @@ XSED=$HOST_SED_DIR/bin/sed
#############################################################
if ! which which > /dev/null ; then
echo "which installed: FALSE"
- echo -e "\n\nYou must install 'which' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'which' on your build machine\n";
exit 1;
fi;
echo "which installed: Ok"
@@ -49,13 +49,13 @@ echo "which installed: Ok"
MAKE=$(which make)
if [ -z "$MAKE" ] ; then
echo "make installed: FALSE"
- echo -e "\n\nYou must install 'make' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'make' on your build machine\n";
exit 1;
fi;
MAKE_VERSION=$($MAKE --version 2>&1 | head -n1 | $XSED -e 's/^.* \([0-9\.]\)/\1/g' -e 's/[-\ ].*//g')
if [ -z "$MAKE_VERSION" ] ; then
echo "make installed: FALSE"
- echo -e "\n\nYou must install 'make' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'make' on your build machine\n";
exit 1;
fi;
MAKE_MAJOR=$(echo $MAKE_VERSION | $XSED -e "s/\..*//g")
@@ -79,14 +79,14 @@ if [ -z "$COMPILER" ] ; then
fi;
if [ -z "$COMPILER" ] ; then
echo "C Compiler installed: FALSE"
- echo -e "\n\nYou must install 'gcc' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'gcc' on your build machine\n";
exit 1;
fi;
COMPILER_VERSION=$($COMPILER --version 2>&1 | head -n1 | $XSED -e 's/^.*(.CC) \([0-9\.]\)/\1/g' -e "s/[-\ ].*//g")
if [ -z "$COMPILER_VERSION" ] ; then
echo "gcc installed: FALSE"
- echo -e "\n\nYou must install 'gcc' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'gcc' on your build machine\n";
exit 1;
fi;
COMPILER_MAJOR=$(echo $COMPILER_VERSION | $XSED -e "s/\..*//g")
@@ -107,7 +107,7 @@ echo "C compiler version '$COMPILER_VERSION': Ok"
#############################################################
if ! which bison > /dev/null ; then
echo "bison installed: FALSE"
- echo -e "\n\nYou must install 'bison' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'bison' on your build machine\n";
exit 1;
fi;
echo "bison installed: Ok"
@@ -120,7 +120,7 @@ echo "bison installed: Ok"
#############################################################
if ! which flex > /dev/null ; then
echo "flex installed: FALSE"
- echo -e "\n\nYou must install 'flex' on your build machine\n";
+ /bin/echo -e "\n\nYou must install 'flex' on your build machine\n";
exit 1;
fi;
echo "flex installed: Ok"
@@ -133,7 +133,7 @@ echo "flex installed: Ok"
#############################################################
if ! which msgfmt > /dev/null ; then \
echo "gettext installed: FALSE"
- echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
+ /bin/echo -e "\n\nYou must install 'gettext' on your build machine\n"; \
exit 1; \
fi;
echo "gettext installed: Ok"
diff --git a/toolchain/kernel-headers/kernel-headers.mk b/toolchain/kernel-headers/kernel-headers.mk
index fa97e9440..54d57db8d 100644
--- a/toolchain/kernel-headers/kernel-headers.mk
+++ b/toolchain/kernel-headers/kernel-headers.mk
@@ -163,11 +163,11 @@ endif
$(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_DIR)/.patched
rm -f $(LINUX_HEADERS_DIR)/include/asm
@if [ ! -f $(LINUX_HEADERS_DIR)/Makefile ] ; then \
- echo -e "VERSION = $(VERSION)\nPATCHLEVEL = $(PATCHLEVEL)\n" > \
+ /bin/echo -e "VERSION = $(VERSION)\nPATCHLEVEL = $(PATCHLEVEL)\n" > \
$(LINUX_HEADERS_DIR)/Makefile; \
- echo -e "SUBLEVEL = $(SUBLEVEL)\nEXTRAVERSION =\n" >> \
+ /bin/echo -e "SUBLEVEL = $(SUBLEVEL)\nEXTRAVERSION =\n" >> \
$(LINUX_HEADERS_DIR)/Makefile; \
- echo -e "KERNELRELEASE=\$$(VERSION).\$$(PATCHLEVEL).\$$(SUBLEVEL)\$$(EXTRAVERSION)" >> \
+ /bin/echo -e "KERNELRELEASE=\$$(VERSION).\$$(PATCHLEVEL).\$$(SUBLEVEL)\$$(EXTRAVERSION)" >> \
$(LINUX_HEADERS_DIR)/Makefile; \
fi;
@if [ "$(ARCH)" = "powerpc" ];then \