summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2012-07-18 15:59:09 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-18 19:33:29 +0200
commit1d4104f0d0428297a8b447a0e08c81a9eaee7f62 (patch)
treec884f651aa8d24715a254077f4f586908eb01623
parent9f16b69c595faf0eb48aa4fa581cbbb0bacde603 (diff)
downloadbuildroot-novena-1d4104f0d0428297a8b447a0e08c81a9eaee7f62.tar.gz
buildroot-novena-1d4104f0d0428297a8b447a0e08c81a9eaee7f62.zip
add host arch detection and Kconfig BR2_HOSTARCH
This will allow to install binary package only if they are supported by the host. As example Atmel SAM-BA (x86 only). Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--Config.in4
-rw-r--r--Makefile10
2 files changed, 14 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index 925c2474c..c182f7044 100644
--- a/Config.in
+++ b/Config.in
@@ -10,6 +10,10 @@ config BR2_VERSION
string
option env="BR2_VERSION_FULL"
+config BR2_HOSTARCH
+ string
+ option env="HOSTARCH"
+
source "target/Config.in.arch"
menu "Build options"
diff --git a/Makefile b/Makefile
index d55b136a8..639fdaa1f 100644
--- a/Makefile
+++ b/Makefile
@@ -32,6 +32,16 @@ ifneq ($(firstword $(sort $(MAKE_VERSION) $(MIN_MAKE_VERSION))),$(MIN_MAKE_VERSI
$(error You have make '$(MAKE_VERSION)' installed. GNU make >= $(MIN_MAKE_VERSION) is required)
endif
+export HOSTARCH := $(shell uname -m | \
+ sed -e s/i.86/x86/ \
+ -e s/sun4u/sparc64/ \
+ -e s/arm.*/arm/ \
+ -e s/sa110/arm/ \
+ -e s/ppc64/powerpc/ \
+ -e s/ppc/powerpc/ \
+ -e s/macppc/powerpc/\
+ -e s/sh.*/sh/)
+
# This top-level Makefile can *not* be executed in parallel
.NOTPARALLEL: