summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-18 06:31:46 -0500
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-11 02:01:10 +0100
commit176afdb3a180e0833d8b0a5085a2745e2b3e2d27 (patch)
tree64ea2b98f489d25c2a057e52a4c060fed344b98e
parent56d387716a7f6f744b1db77c69d661051db6e9d0 (diff)
downloadbuildroot-novena-176afdb3a180e0833d8b0a5085a2745e2b3e2d27.tar.gz
buildroot-novena-176afdb3a180e0833d8b0a5085a2745e2b3e2d27.zip
linux: add shorter shortcuts
We only have one Linux kernel package, and "linux26-" is an anachronism in today's world. So add useful "linux-%" shortcuts to the "linux26-%". Signed-off-by: Mike Frysinger <vapier@gentoo.org> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--docs/README2
-rw-r--r--docs/buildroot.html2
-rw-r--r--linux/linux.mk3
3 files changed, 5 insertions, 2 deletions
diff --git a/docs/README b/docs/README
index c330a606b..e756329b5 100644
--- a/docs/README
+++ b/docs/README
@@ -53,7 +53,7 @@ $ make HOSTCC=gcc-4.3.orig HOSTCXX=gcc-4.3-mine
Depending on your configuration, there are some targets you can use to
use menuconfig of certain packages. This includes:
-$ make HOSTCC=gcc-4.3 linux26-menuconfig
+$ make HOSTCC=gcc-4.3 linux-menuconfig
$ make HOSTCC=gcc-4.3 uclibc-menuconfig
$ make HOSTCC=gcc-4.3 busybox-menuconfig
diff --git a/docs/buildroot.html b/docs/buildroot.html
index b6cf578bd..8293c8fec 100644
--- a/docs/buildroot.html
+++ b/docs/buildroot.html
@@ -434,7 +434,7 @@
<p>The Linux kernel configuration can be customized just like
<a href="#custom_busybox">BusyBox</a> and
- <a href="#custom_uclibc">uClibc</a> using <code>make linux26-menuconfig
+ <a href="#custom_uclibc">uClibc</a> using <code>make linux-menuconfig
</code>. Make sure you have enabled the kernel build in <code>make
menuconfig</code> first. Once done, run <code>make</code> to (re)build
everything.</p>
diff --git a/linux/linux.mk b/linux/linux.mk
index ab90c03e4..5f89b7dd3 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -179,3 +179,6 @@ endif
endif
endif
+
+linux-%:
+ $(MAKE) $(subst linux-,linux26-,$@)