summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2005-08-04 05:44:48 +0000
committerManuel Novoa III <mjn3@codepoet.org>2005-08-04 05:44:48 +0000
commit1172dbb8b15c2ccddfa9492850d2f6fbb61e2263 (patch)
treeba87cc97ca030c0e97cb94a12c73c0a0af249f6c
parent1e218e33ebed5c3c434fcb3377d225d253d97128 (diff)
downloadbuildroot-novena-1172dbb8b15c2ccddfa9492850d2f6fbb61e2263.tar.gz
buildroot-novena-1172dbb8b15c2ccddfa9492850d2f6fbb61e2263.zip
Sigh... Let's try this again.
-rw-r--r--toolchain/Config.in2
-rw-r--r--toolchain/gdb/gdb.mk1
2 files changed, 1 insertions, 2 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index 8597ac399..952219afd 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -46,7 +46,7 @@ config BR2_TARGET_OPTIMIZATION
Optimizations to use when building for the target host.
config BR2_CROSS_TOOLCHAIN_TARGET_UTILS
- string "Include target utils in cross toolchain."
+ bool "Include target utils in cross toolchain."
default y
help
When using buildroot to build a deployable cross toolchain, it is handy
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 95d6d3dae..86264b583 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -121,7 +121,6 @@ $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
$(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_SERVER_DIR)
$(STRIP) $(GDB_SERVER_DIR)/gdbserver
-
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
ifeq ($(strip $(BR2_CROSS_TOOLCHAIN_TARGET_UTILS)),y)
mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/target_utils