summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvan Zelkowitz <evan.zelkowitz@gmail.com>2009-07-18 11:29:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-18 11:30:12 +0200
commit10e9b7ed08fb8a69796d0e486e74a343b24bb78d (patch)
tree5d30ece534b4ff081250aa39eb4145bca7eb0e14
parentb09d8a72d2efe07bf996406deff5ded22652046f (diff)
downloadbuildroot-novena-10e9b7ed08fb8a69796d0e486e74a343b24bb78d.tar.gz
buildroot-novena-10e9b7ed08fb8a69796d0e486e74a343b24bb78d.zip
sdl_gfx: new package
Closes #369. [Peter: Minor tweaks] Signed-off-by: Evan Zelkowitz <evan.zelkowitz@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES1
-rw-r--r--package/Config.in1
-rw-r--r--package/sdl_gfx/Config.in10
-rw-r--r--package/sdl_gfx/sdl_gfx.mk26
4 files changed, 38 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 61a79b9be..781f5cfd1 100644
--- a/CHANGES
+++ b/CHANGES
@@ -9,6 +9,7 @@
#349: update libsoup to version 2.26.2
#359,#413: Upgrade openvpn to Makefile.autotools.in
#367: linux kernel compile error for arm926t
+ #369: Add SDL_gfx package
#373: Support for building gstreamer without libxml
#379: update DirectFB to version 1.4.0
#383: gst-plugins-good: Allow soup plugin to be configured
diff --git a/package/Config.in b/package/Config.in
index cb8356311..4a943a869 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -306,6 +306,7 @@ source "package/sdl_image/Config.in"
source "package/sdl_mixer/Config.in"
source "package/sdl_net/Config.in"
source "package/sdl_ttf/Config.in"
+source "package/sdl_gfx/Config.in"
source "package/tiff/Config.in"
comment "busybox graphic applications"
diff --git a/package/sdl_gfx/Config.in b/package/sdl_gfx/Config.in
new file mode 100644
index 000000000..4910b2d64
--- /dev/null
+++ b/package/sdl_gfx/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_SDL_GFX
+ bool "SDL_gfx"
+ depends on BR2_PACKAGE_SDL
+ help
+ The SDL_gfx library is an extension to the SDL library which
+ provides basic antialiased drawing routines such as lines,
+ circles or polygons, an interpolating rotozoomer for SDL
+ surfaces, framerate control and MMX image filters.
+
+ http://www.ferzkopp.net/joomla/content/view/19/14/
diff --git a/package/sdl_gfx/sdl_gfx.mk b/package/sdl_gfx/sdl_gfx.mk
new file mode 100644
index 000000000..bd4e3f154
--- /dev/null
+++ b/package/sdl_gfx/sdl_gfx.mk
@@ -0,0 +1,26 @@
+#############################################################
+#
+# SDL_gfx addon for SDL
+#
+#############################################################
+SDL_GFX_VERSION:=2.0.19
+SDL_GFX_SOURCE:=SDL_gfx-$(SDL_GFX_VERSION).tar.gz
+SDL_GFX_SITE:=http://www.ferzkopp.net/Software/SDL_gfx-2.0/
+SDL_GFX_LIBTOOL_PATCH:=NO
+SDL_GFX_INSTALL_STAGING:=YES
+SDL_GFX_INSTALL_TARGET:=YES
+
+SDL_GFX_DEPENDENCIES:=sdl
+
+SDL_GFX_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
+ --disable-sdltest \
+ --enable-static
+
+# enable mmx for newer x86's
+ifeq ($(BR2_i386)$(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
+SDL_GFX_CONF_OPT += --enable-mmx
+else
+SDL_GFX_CONF_OPT += --disable-mmx
+endif
+
+$(eval $(call AUTOTARGETS,package,sdl_gfx))