summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Spence <jspence@uclibc.org>2008-03-28 02:50:42 +0000
committerJason Spence <jspence@uclibc.org>2008-03-28 02:50:42 +0000
commit0d17acf4cffd53e9eb21096e037b1f96d190780a (patch)
tree46cbe50b7701ec213d867fcf80625183600110ef
parent1ab26cfe3868a95211baf488d40710f6e31307fc (diff)
downloadbuildroot-novena-0d17acf4cffd53e9eb21096e037b1f96d190780a.tar.gz
buildroot-novena-0d17acf4cffd53e9eb21096e037b1f96d190780a.zip
Added ccache support and removed grub from defconfig due to brokenness at the moment.
-rw-r--r--.defconfig4
-rw-r--r--Makefile11
2 files changed, 13 insertions, 2 deletions
diff --git a/.defconfig b/.defconfig
index c98b192e6..866c60ba1 100644
--- a/.defconfig
+++ b/.defconfig
@@ -628,8 +628,8 @@ BR2_GAMES=y
#
# bootloader for target device
#
-BR2_TARGET_GRUB=y
-BR2_TARGET_GRUB_SPLASH=y
+# BR2_TARGET_GRUB is not set
+# BR2_TARGET_GRUB_SPLASH is not set
# BR2_TARGET_GRUB_DISKLESS is not set
# BR2_TARGET_GRUB_3c595 is not set
# BR2_TARGET_GRUB_3c90x is not set
diff --git a/Makefile b/Makefile
index 1aca7885a..9f9f0628d 100644
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,11 @@ CONFIG_SHELL:=$(shell if [ -x "$$BASH" ]; then echo $$BASH; \
export CONFIG_SHELL quiet Q KBUILD_VERBOSE VERBOSE
+HOSTCCACHE:=$(shell $(CONFIG_SHELL) -c "which ccache")
+ifneq ($(HOSTCCACHE),)
+BR2_HAVE_HOST_CCACHE=y
+endif
+
ifndef HOSTAR
HOSTAR:=ar
endif
@@ -124,6 +129,12 @@ endif
ifndef FCFLAGS_FOR_BUILD
FCFLAGS_FOR_BUILD:=-g -O2
endif
+
+ifeq ($(BR2_HAVE_HOST_CCACHE),y)
+HOSTCC:=$(HOSTCCACHE) $(HOSTCC)
+HOSTCXX:=$(HOSTCCACHE) $(HOSTCXX)
+endif
+
export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD