summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-05-30 23:57:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-12 21:59:34 +0200
commit009d8fceab4db7815502e4b0565fe0ef531d512c (patch)
tree3a1b28288d5d6a17241bfd3ff8d7cd59fa8730aa
parent97fafb9adc0fc8a3610fe28e8394accf96ad0a9c (diff)
downloadbuildroot-novena-009d8fceab4db7815502e4b0565fe0ef531d512c.tar.gz
buildroot-novena-009d8fceab4db7815502e4b0565fe0ef531d512c.zip
package/autotools: add --{enable,disable}-{shared,static} automatically
For target packages, depending on BR2_PREFER_STATIC_LIB, add the correct combination of --{enable,disable}-{shared,static} flags to ./configure calls. * When BR2_PREFER_STATIC_LIB is enabled, we pass --enable-static --disable-shared. * When BR2_PREFER_STATIC_LIB is disabled, we pass --enable-static --enable-shared. We enable static libraries since they can still be useful to statically link applications against some libraries (sometimes it is useful for size reasons). Static libraries are anyway only installed in the STAGING_DIR, so it doesn't increase in any way the size of the TARGET_DIR. For host packages, always pass --enable-shared and --disable-static. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.autotools.in2
-rw-r--r--package/Makefile.in6
2 files changed, 8 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 917600ca0..46ab861c1 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -104,6 +104,7 @@ define $(2)_CONFIGURE_CMDS
$$(DISABLE_NLS) \
$$(DISABLE_LARGEFILE) \
$$(DISABLE_IPV6) \
+ $$(SHARED_STATIC_LIBS_OPTS) \
$$(QUIET) $$($$(PKG)_CONF_OPT) \
)
endef
@@ -119,6 +120,7 @@ define $(2)_CONFIGURE_CMDS
./configure \
--prefix="$$(HOST_DIR)/usr" \
--sysconfdir="$$(HOST_DIR)/etc" \
+ --enable-shared --disable-static \
$$($$(PKG)_CONF_OPT) \
)
endef
diff --git a/package/Makefile.in b/package/Makefile.in
index 31a963920..8e9637ce8 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -276,6 +276,12 @@ else
ENABLE_DEBUG:=
endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+SHARED_STATIC_LIBS_OPTS=--enable-static --disable-shared
+else
+SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
+endif
+
include package/Makefile.autotools.in
include package/Makefile.cmake.in
include package/Makefile.package.in