aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNick Fitzgerald <fitzgen@gmail.com>2010-06-29 21:18:53 -0700
committerNick Fitzgerald <fitzgen@gmail.com>2010-06-29 21:18:53 -0700
commit993fbde068c7cad977aa2be857237f6ab7d018f1 (patch)
tree6162725ff340ccd8d3d0c41969545ad835305f13 /setup.py
parentd22799ca1d63e55d88fe0a3adf4c71904a591012 (diff)
downloadpycco-993fbde068c7cad977aa2be857237f6ab7d018f1.tar.gz
pycco-993fbde068c7cad977aa2be857237f6ab7d018f1.zip
Fixing up pocco to work with files that dont have an extension and adding the setup.py script
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f359b6d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,10 @@
+from setuptools import setup
+
+setup(name="Pocco",
+ version="0.1",
+ description="""A Python port of Docco: the original quick-and-dirty, hundred-line-long,
+ literate-programming-style documentation generator.""",
+ author="Nick Fitzgerald",
+ author_email="fitzgen@gmail.com",
+ url="http://fitzgen.github.com/pocco",
+ scripts=["pocco"])