aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 12 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b50db83..4cae79d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,22 +5,27 @@ version = "0.0.1"
authors = ["tomaka <pierre.krieger1708@gmail.com>"]
[features]
-default = ["cocoa", "window"]
+default = ["window"]
window = []
headless = []
[dependencies.compile_msg]
git = "https://github.com/huonw/compile_msg"
-[dependencies.android_glue]
-git = "https://github.com/tomaka/android-rs-glue"
-
[dependencies.gl_generator]
git = "https://github.com/bjz/gl-rs"
-[dependencies.cocoa]
+[target.arm-linux-androideabi.dependencies.android_glue]
+git = "https://github.com/tomaka/android-rs-glue"
+
+[target.i686-apple-darwin.dependencies.cocoa]
git = "https://github.com/DavidPartouche/rust-cocoa"
-optional = true
-[dependencies.core_foundation]
+[target.x86_64-apple-darwin.dependencies.cocoa]
+git = "https://github.com/DavidPartouche/rust-cocoa"
+
+[target.i686-apple-darwin.dependencies.core_foundation]
+git = "https://github.com/servo/rust-core-foundation"
+
+[target.x86_64-apple-darwin.dependencies.core_foundation]
git = "https://github.com/servo/rust-core-foundation"