aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authortomaka <pierre.krieger1708@gmail.com>2015-05-07 16:42:21 +0200
committertomaka <pierre.krieger1708@gmail.com>2015-05-07 16:42:21 +0200
commit5e2001791d70b71ee97ed88ac28067e74dafd92d (patch)
tree135ebb64bc963064d71e613637d246de1d43afbd /Cargo.toml
parent3e29c6585b23fbf0df2c254001ef988716771311 (diff)
parent7ee416ab883add82afd3ab96eb5616472c8cdfcd (diff)
downloadglutin-5e2001791d70b71ee97ed88ac28067e74dafd92d.tar.gz
glutin-5e2001791d70b71ee97ed88ac28067e74dafd92d.zip
Merge pull request #434 from tomaka/x11-dynamic
Make X11 dynamic
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 13 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f14ea8d..d959351 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -51,13 +51,23 @@ kernel32-sys = "0.1"
[target.i686-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = "*"
-x11 = "*"
+
+[target.i686-unknown-linux-gnu.dependencies.x11]
+version = "*"
+features = ["dynamic"]
[target.x86_64-unknown-linux-gnu.dependencies]
osmesa-sys = "0.0.5"
wayland-client = "*"
-x11 = "*"
+
+[target.x86_64-unknown-linux-gnu.dependencies.x11]
+version = "*"
+features = ["dynamic"]
[target.arm-unknown-linux-gnueabihf.dependencies]
osmesa-sys = "0.0.5"
-x11 = "*"
+wayland-client = "*"
+
+[target.arm-unknown-linux-gnueabihf.dependencies.x11]
+version = "*"
+features = ["dynamic"]