aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorTomaka17 <pierre.krieger1708@gmail.com>2014-10-21 21:23:51 +0200
committerTomaka17 <pierre.krieger1708@gmail.com>2014-10-21 21:25:30 +0200
commit1d9ceb9ddff11c3511cfe7a847ff26e67d3b5f30 (patch)
tree93c7620cd9231e015335310b9d05d61202e1cef3 /Cargo.toml
parentc8ea2bf587429b5b59d5a41f7ebb16a7998badd9 (diff)
downloadglutin-1d9ceb9ddff11c3511cfe7a847ff26e67d3b5f30.tar.gz
glutin-1d9ceb9ddff11c3511cfe7a847ff26e67d3b5f30.zip
Update for Cargo's platform-specific dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 9 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b50db83..0ed3e06 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,7 +5,7 @@ version = "0.0.1"
authors = ["tomaka <pierre.krieger1708@gmail.com>"]
[features]
-default = ["cocoa", "window"]
+default = ["window"]
window = []
headless = []
@@ -18,9 +18,14 @@ git = "https://github.com/tomaka/android-rs-glue"
[dependencies.gl_generator]
git = "https://github.com/bjz/gl-rs"
-[dependencies.cocoa]
+[target.i686-apple-darwin.dependencies.cocoa]
git = "https://github.com/DavidPartouche/rust-cocoa"
-optional = true
-[dependencies.core_foundation]
+[target.x86_64-apple-darwin.dependencies.cocoa]
+git = "https://github.com/DavidPartouche/rust-cocoa"
+
+[target.i686-apple-darwin.dependencies.core_foundation]
+git = "https://github.com/servo/rust-core-foundation"
+
+[target.x86_64-apple-darwin.dependencies.core_foundation]
git = "https://github.com/servo/rust-core-foundation"