aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xfce-macros/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/xfce-macros/Makefile')
-rw-r--r--tools/xfce-macros/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/xfce-macros/Makefile b/tools/xfce-macros/Makefile
new file mode 100644
index 000000000..974404714
--- /dev/null
+++ b/tools/xfce-macros/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xfce-macros
+PKG_VERSION:=4.8.0
+
+PKG_SOURCE_URL:=http://archive.xfce.org/xfce/4.8/src
+PKG_SOURCE:=xfce4-dev-tools-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=9591299c49d92d00ba47974c42a735fa
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/xfce4-dev-tools-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/share/aclocal
+ $(INSTALL_DATA) $(HOST_BUILD_DIR)/m4macros/*.m4 $(STAGING_DIR_HOST)/share/aclocal/
+endef
+
+$(eval $(call HostBuild))