aboutsummaryrefslogtreecommitdiffstats
path: root/tools/upslug2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/upslug2/Makefile')
-rw-r--r--tools/upslug2/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/upslug2/Makefile b/tools/upslug2/Makefile
new file mode 100644
index 000000000..e80cef0eb
--- /dev/null
+++ b/tools/upslug2/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=upslug2
+PKG_VERSION:=20071227
+
+PKG_SOURCE_URL:=http://svn.nslu2-linux.org/svnroot/upslug2/trunk
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_SUBDIR:=upslug2-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=41
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); \
+ aclocal && autoconf && \
+ autoheader && \
+ automake --add-missing; \
+ )
+ $(Host/Configure/Default)
+endef
+
+ifneq ($(HOST_OS),Linux)
+ HOST_CONFIGURE_ARGS += --with-libpcap
+endif
+
+$(eval $(call HostBuild))