aboutsummaryrefslogtreecommitdiffstats
path: root/tools/sstrip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/sstrip/Makefile')
-rw-r--r--tools/sstrip/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/sstrip/Makefile b/tools/sstrip/Makefile
new file mode 100644
index 000000000..ea4c3e880
--- /dev/null
+++ b/tools/sstrip/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sstrip
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(HOSTCC) $(HOST_CFLAGS) -I./include -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
+endef
+
+define Host/Install
+ $(CP) $(HOST_BUILD_DIR)/sstrip $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/sstrip
+endef
+
+$(eval $(call HostBuild))