aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt/patches/100-patch_2.6.1_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/quilt/patches/100-patch_2.6.1_version.patch')
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644
index 000000000..1e9ed75df
--- /dev/null
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,11 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version