aboutsummaryrefslogtreecommitdiffstats
path: root/tools/quilt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/quilt/Makefile')
-rw-r--r--tools/quilt/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/tools/quilt/Makefile b/tools/quilt/Makefile
new file mode 100644
index 000000000..510d8f6fd
--- /dev/null
+++ b/tools/quilt/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 -2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=quilt
+PKG_VERSION:=0.48
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/$(PKG_NAME)
+PKG_MD5SUM:=f77adda60039ffa753f3c584a286f12b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+GETOPT:=$(shell which getopt)
+
+HOST_CONFIGURE_ARGS += \
+ --with-patch=$(PATCH) \
+ --with-find=$(FIND) \
+ --with-getopt=$(GETOPT)
+
+define Host/Configure
+ cd $(HOST_BUILD_DIR) && autoconf
+ $(call Host/Configure/Default)
+ [ -f $(HOST_BUILD_DIR)/Makefile ]
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" all lib/backup-files
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" install
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/quilt
+endef
+
+$(eval $(call HostBuild))