aboutsummaryrefslogtreecommitdiffstats
path: root/tools/ppl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/ppl/Makefile')
-rw-r--r--tools/ppl/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
new file mode 100644
index 000000000..46c966d82
--- /dev/null
+++ b/tools/ppl/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ppl
+PKG_VERSION:=0.10.2
+
+PKG_SOURCE_URL:=ftp://gcc.gnu.org/pub/gcc/infrastructure
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=e7dd265afdeaea81f7e87a72b182d875
+
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR)/$(3); \
+ $(HOST_CONFIGURE_CMD) \
+ $(HOST_CONFIGURE_VARS) \
+ $(HOST_CONFIGURE_ARGS); \
+ )
+endef
+
+
+$(eval $(call HostBuild))