aboutsummaryrefslogtreecommitdiffstats
path: root/tools/patch-cmdline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/patch-cmdline/Makefile')
-rw-r--r--tools/patch-cmdline/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/patch-cmdline/Makefile b/tools/patch-cmdline/Makefile
new file mode 100644
index 000000000..a9526397f
--- /dev/null
+++ b/tools/patch-cmdline/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2007-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=patch-cmdline
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(HOSTCC) $(HOST_CFLAGS) -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/$(PKG_NAME) src/$(PKG_NAME).c
+endef
+
+define Host/Install
+ $(CP) $(HOST_BUILD_DIR)/patch-cmdline $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/patch-cmdline
+endef
+
+$(eval $(call HostBuild))