aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mtools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mtools/Makefile')
-rw-r--r--tools/mtools/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/mtools/Makefile b/tools/mtools/Makefile
new file mode 100644
index 000000000..8d227c147
--- /dev/null
+++ b/tools/mtools/Makefile
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+ rm -f $(STAGING_DIR_HOST)/bin/mcopy
+endef
+
+$(eval $(call HostBuild))