aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpfr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mpfr/Makefile')
-rw-r--r--tools/mpfr/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
new file mode 100644
index 000000000..55c329ff8
--- /dev/null
+++ b/tools/mpfr/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=3.0.0
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=f45bac3584922c8004a10060ab1a8f9f
+
+HOST_BUILD_PARALLEL:=1
+HOST_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))