aboutsummaryrefslogtreecommitdiffstats
path: root/tools/mpc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mpc/Makefile')
-rw-r--r--tools/mpc/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
new file mode 100644
index 000000000..adbe33e0b
--- /dev/null
+++ b/tools/mpc/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpc
+PKG_VERSION:=0.9
+
+PKG_SOURCE_URL:=http://www.multiprecision.org/mpc/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=0d6acab8d214bd7d1fbbc593e83dd00d
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-mpfr=$(TOPDIR)/staging_dir/host \
+ --with-gmp=$(TOPDIR)/staging_dir/host
+
+$(eval $(call HostBuild))