aboutsummaryrefslogtreecommitdiffstats
path: root/tools/m4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/m4/Makefile')
-rw-r--r--tools/m4/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
new file mode 100644
index 000000000..080eb5d99
--- /dev/null
+++ b/tools/m4/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=m4
+PKG_VERSION:=1.4.16
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
+PKG_CAT:=zcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_VARS += gl_cv_func_strstr_linear=no
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))