aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/gmp/Makefile')
-rw-r--r--tools/gmp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
new file mode 100644
index 000000000..292d9a5b3
--- /dev/null
+++ b/tools/gmp/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gmp
+PKG_VERSION:=5.0.5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/gmp/
+PKG_MD5SUM:=8aef50959acec2a1ad41d144ffe0f3b5
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --enable-cxx \
+ --enable-mpbsd
+
+$(eval $(call HostBuild))