aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/patches/000-relocatable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/patches/000-relocatable.patch')
-rw-r--r--tools/bison/patches/000-relocatable.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/bison/patches/000-relocatable.patch b/tools/bison/patches/000-relocatable.patch
new file mode 100644
index 000000000..50dca6d33
--- /dev/null
+++ b/tools/bison/patches/000-relocatable.patch
@@ -0,0 +1,20 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
+
+ yacc:
+ echo '#! /bin/sh' >$@
++ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ chmod a+x $@
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -1609,6 +1609,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+
+ yacc:
+ echo '#! /bin/sh' >$@
++ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
+ echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
+ chmod a+x $@
+