aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bison/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison/Makefile')
-rw-r--r--tools/bison/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/bison/Makefile b/tools/bison/Makefile
new file mode 100644
index 000000000..ef705227e
--- /dev/null
+++ b/tools/bison/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bison
+PKG_VERSION:=2.5
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=9dba20116b13fc61a0846b0058fbe004
+PKG_CAT:=bzcat
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))