aboutsummaryrefslogtreecommitdiffstats
path: root/tools/autoconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/autoconf/Makefile')
-rw-r--r--tools/autoconf/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/tools/autoconf/Makefile b/tools/autoconf/Makefile
new file mode 100644
index 000000000..f5d22c3ff
--- /dev/null
+++ b/tools/autoconf/Makefile
@@ -0,0 +1,37 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=autoconf
+PKG_VERSION:=2.68
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/autoconf
+PKG_MD5SUM:=864d785215aa60d627c91fcb21b05b07
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Configure
+ $(call Host/Configure/Default,\
+ --datarootdir=$(STAGING_DIR_HOST)/share \
+ )
+endef
+
+define Host/Compile
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+ -export SHELL="$(BASH)"; $(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))